Consumir web service externo a partir das ferramentas do ERP Sapiens

  • # 10 meses, 1 semana atrás

    Boa noite a todos.

    Estamos trabalhando no desenvolvimento de interface para integrar nosso sistema ERP Sapiens fazendo uso das ferramentas de desenvolvimento disponibilizadas.
    Estamos enfrentando problemas com a limitação TLS 1.0 existente nas Ferramentas do ERP.
    Segundo o suporte não há previsão para liberação da devida atualização para a descontinuação do TLS 1.0 e 1.1.
    Alguém por aqui fazendo uso das ferramentas para consumo de webservices que aceitem somente a versão TLS 1.2 ou superior?

    Agradeço qualquer dica .

    Márcio Almeida

    # 10 meses atrás

    Olá Márcio tudo bem?

    Não sei se consegui entender corretamente qual é a situação… É sobre as APIs SOAP do ERP Server que são disponibilizadas no Glassfish?

    Você pode dar mais detalhes do problema que vc está passando?

    Obrigado!
    Roque Possamai.

    gsbarizao
    Participante
    # 2 meses, 2 semanas atrás

    Eu acho que entendi a dúvida do Marcio, pois já tive esse problema.
    Tentei consumir uma API Rest de um terceiro, de dentro do ERP G5, utilizando as funções http (httpget ou httppost), e a API do terceiro não aceita a TLS 1.1 (apenas versões superiores).
    Veja no link abaixo:
    https://suporte.senior.com.br/hc/pt-br/articles/4409379777684-25825-HTTP-2-0-Fun%C3%A7%C3%A3o-HTTPPost?resultadoPesquisa

Visualizando 3 posts - 1 até 3 (de 3 do total)

You must be logged in to reply to this topic.